Discussion:
radeon 9200 ajurit
(too old to reply)
Mikko
2003-08-22 17:38:44 UTC
Permalink
Onko kenelläkään radeon 9200 korttia?

Millä ajureilla tuota olisi paras käyttää?

"vesa" ajurilla kuva jäi jostain syystä 60 Herziin.

Nyt on ajurina ATI radeon 8500, jonka "test" ei mennyt läpi (ilmeisesti
kortin tunnistus ei kelvannut), mutta kun valitsin radeon 8500 ajurin ilman
testiä, ja kävin XF86Config-4 ään lisäämässä deviceen rivit:

BusID "PCI:1:0:0"
ChipID 0x4242

tunnistuu se readeon 8500seksi ja toimii

toinen vaihtoehto olisi ChipID 0x514D (9100, kun 0x4242 on 8500) jota en ole
kokeillut.


Mutta eikö radeonille pitäisi olla jotain r200, r250, r280 tms. ajureita
9000 sarjalle? Ainakaan minun Xfree:ssä, 4.3.x tai jotain ei ole listassa
tuollaisia ajureita.
Sami Ketola
2003-08-22 18:56:04 UTC
Permalink
Post by Mikko
Onko kenelläkään radeon 9200 korttia?
Millä ajureilla tuota olisi paras käyttää?
<URL: http://www.schneider-digital.de/html/body_download_ati.html>

ja sieltä glx1_linux_X4.3.zip

Sami
--
${HOME}/.signature: cannot open: No such file or directory.
Pekko Piirola
2003-08-23 06:06:14 UTC
Permalink
Post by Mikko
Onko kenelläkään radeon 9200 korttia?
Millä ajureilla tuota olisi paras käyttää?
XFree86 tukee kortin 2D-kiihdytyksiä versiosta 4.3.0 eteenpäin.
3D-ominaisuuksiin tarvitset DRI-ajurin, joka löytyy sourceforgesta:
<http://dri.sourceforge.net/>.
Post by Mikko
Mutta eikö radeonille pitäisi olla jotain r200, r250, r280 tms. ajureita
9000 sarjalle? Ainakaan minun Xfree:ssä, 4.3.x tai jotain ei ole listassa
tuollaisia ajureita.
Minulla toimi 9700:n kanssa X 4.3.0:lla tämä, luulisi vastaavan
toimivan 9200:llakin:

Section "Device"
Identifier "Club3D Radeon 9700"
BusID "PCI:3:0:0"
Driver "radeon"
Option "UseFBDev" "true"
Option "AGPMode" "4"
Option "AGPFastWrite" "true"
EndSection
--
Voikaa hyvin!
t: Pekko
Mikko Paananen
2003-08-23 10:43:24 UTC
Permalink
Post by Mikko
Onko kenelläkään radeon 9200 korttia?
Millä ajureilla tuota olisi paras käyttää?
Nyt on ajurina ATI radeon 8500, jonka "test" ei mennyt läpi (ilmeisesti
kortin tunnistus ei kelvannut), mutta kun valitsin radeon 8500 ajurin ilman
BusID "PCI:1:0:0"
ChipID 0x4242
tunnistuu se readeon 8500seksi ja toimii
Jos se toimii niin anna olla.
Post by Mikko
Mutta eikö radeonille pitäisi olla jotain r200, r250, r280 tms. ajureita
9000 sarjalle? Ainakaan minun Xfree:ssä, 4.3.x tai jotain ei ole listassa
tuollaisia ajureita.
Hmmm,

"The R9100 is a relabelled R8500LE, and the R9200 is a relabelled full
blown R8500. The R8500LE/8500/9100/9200 all use the same core. The
difference being that the R8500LE/9100 are clocked @ 250/500mhz
core/memory, and the R9200 are clocked @ 275/550mhz core/memory." [1]

"9200 uses the RV280 chip, which is a development of RV250, also based
on Radeon 8500/9100's R200 core, but cut back to meet the entry level
market. RV280 holds the exact same core configuration as RV250, but
with the addition of full AGP8X support." [2]

XFree 4.3.0:ssa on r200:lle jonkinlainen 3d tuki, nuo uudemmat mallit
ovat varmaan uudempia kuin xfree 4.3.0 joten niille ei ole ajureissa
chipid:tä valmiiksi. Atin mallinimistä kun ei ota hullukaan selvää.

1) http://www.tech-report.com/forums/viewtopic.php?t=7643
2) http://www.beyond3d.com/reviews/sapphire/9200/
--
// ***@tut.fi / http://cydonia.ton.tut.fi //
Kalle Olavi Niemitalo
2003-08-23 20:39:24 UTC
Permalink
Post by Mikko Paananen
Atin mallinimistä kun ei ota hullukaan selvää.
http://dri.sourceforge.net/doc/radeon_naming.phtml
Antti Järvinen
2003-08-31 08:25:04 UTC
Permalink
Itse tuossa kanssa tapellut saman asian kanssa. Itselläni on vielä
tuosta Radeon 9200 kortista se SE malli ( slow edition/second edition ...
;) )
Itse sain toimimaan tämän SE-Mallin asettamalla nuo BusID ja
ChipID numerot kohdalleen. Se että ottaako tämä irti kortista
kaikkia tehoja irti ei ole varmaa, mutta saipahan ainakin kortin kunnolla
toimimaan.
Siis toimimaan tuolla atin omalla ajurilla vai dri-poppoon ajurilla vai sillä
mikä tulee 4.3.0:n mukana? Mulla atin oma binääriajuuri sanoo että
"no devices found" ja ei rupea millekään. Dri-poppoon ajuuri lähtee käyntiin
ja näyttää muuten tosi hyvältä paitsi että kaikki 3d-hässäköinti tehdäänkin
softalla, kortin 3d-rauta ei jostain syystä ole käytössä. Parasta tässä on
se, että glxinfo sanoo toisin, samoin kun panee jonkun tuxracerin tulille
niin sen pid näkyy tuolla /proc/dri -dirikassa jossain "asiakkaat" tiedostossa
ja sitten kaikki renderointi tehdään h-i-t-a-a-s-t-i softalla.

tosi hienoa.

vesa-ajuri pelaa aivan hyvin. silläkään ei pelata paljon muita pelejä
kuin nethackkia.

Postittaisitko xf86config-4:n ja vähän listaa että minkä version softia
sulla on asennettuna?
--
Antti Järvinen, ***@iki.fi
"concerto for two faggots and orchestra"
Continue reading on narkive:
Loading...